読者です 読者をやめる 読者になる 読者になる

Bash on Ubuntu on WindowsにRailsをインストールするときに詰まったところ

nokogiriのインストール

Macの情報はたくさん書かれているが、Ubuntuの情報はあまり無かったので苦労した。

$ bundle config build.nokogiri --use-system-libraries
$ sudo apt-get install libxslt-dev libxml2-dev
$ cd /usr/include
$ sudo ln -s ./libxml2/libxml libxml # macでのbrew linkに相当

jsonのインストール

jsonのversionを1.8.5以上にすればいいらしく、そのためには以下のようにすればいいらしい。

$ gem 'json', github: 'flori/json', branch: 'v1.8'